.NET Framework 2.0 Service Pack 1 Vista (coup de gueule !)

 

ERRATA : Je n'avais pas compris la logique de Microsoft, Pour mettre a jour le Framework 2.0 sur windows vista (SP1) , il faut passer le SP1 du Framework 3.0 qui l'inclu.

Donc juste une petite remarque relative au message d'erreur indiqué : Le programme d'installation a detecté que cet ordinateur ne repond pas aux exigences relatives à l'installation de ce logiciel.

Il eu été plus indiqué d'ecrire, Ce service pack ne peut s'installer qu'inclu avec le service pack du framework 3.0.

 

 

Depuis le 20 novembre 2007 , le sp1 pour le .Net Framework 2.0 est sorti, mais uniquement pour windows 2003 et windows XP

http://www.microsoft.com/downloads/details.aspx?FamilyID=79bc3b77-e02c-4ad3-aacf-a7633f706ba5&DisplayLang=en

Comme tout bon geek qui se respecte j'ai acheté une licence pour Vista PRO, et qu'elle n'est pas ma deception de voir que pour Microsoft ce n'est pas le systeme d'exploitation privilegié pour sortir les patchs, a l'heure actuelle sur un soft que nous sommes en train de developper, un bug très bloquant lié a la datagridview subsiste alors que le SP1 le corrige sur XP.

netfx2sp1

A quand un service pack 1 du framework 2.0 pour vista ?

Merci cyril pour ton commentaire, voir ci-dessous l'explication, j'avais installé le framework 3.5 et avait vu qu'il corrigait le pb, je ne savais pas que le SP1 du framework 3.0 passait aussi le SP1 du framework 2.0.

3 commentaires:

cyril a dit…

.net 3.0 est inclut dans Vista (et nécessite .net 2.0)

.net 3.0 SP1 inclut naturellement .net 2.0 SP1 ...

Comme .net 3 est obligatoirement présent sur Vista il n'est pas étonnant que le SP1 de .net 2.0 ne fonctionne pas :

pour télécharger .net 3.0 SP1 :
http://www.microsoft.com/downloads/details.aspx?FamilyId=EC2CA85D-B255-4425-9E65-1E88A0BDB72A&displaylang=en

Rodolphe a dit…

l'install ne fonctionne pas sous vista...
cf. site de MS :
"Supported Operating Systems: Windows Server 2003; Windows XP"

J'ai testé l'install et effectivement ca ne fonctionne pas sous Vista

Rodolphe a dit…

l'install ne fonctionne pas sous vista...
cf. site de MS :
"Supported Operating Systems: Windows Server 2003; Windows XP"

J'ai testé l'install et effectivement ca ne fonctionne pas sous Vista